RAGGED HIERARCHIES: BUILDING DATA DISCOVERY APPLICATIONS TO VIEW REPORTS WITH RAGGED HIERARCHIES
# TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>WORKSHOP BACKGROUND</td>
<td>3</td>
</tr>
<tr>
<td>GETTING STARTED</td>
<td>4</td>
</tr>
<tr>
<td>CONNECT TO DATA FROM AN MDX CUBE</td>
<td>4</td>
</tr>
<tr>
<td>ANALYZE YOUR DATA</td>
<td>7</td>
</tr>
<tr>
<td>VISUALIZE YOUR DATA</td>
<td>20</td>
</tr>
<tr>
<td>USING THE LIBRARY</td>
<td>37</td>
</tr>
</tbody>
</table>
WORKSHOP BACKGROUND

In many organizations, information is often organized hierarchically. Depending on the data, these hierarchies can be either balanced or unbalanced. In a balanced hierarchy, each branch of the hierarchy descends to a common bottom level. The following is a good example of a balanced hierarchy for the Time dimension. In this example, each branch descends to the Month level.

![Balanced Hierarchy Diagram]

In an unbalanced hierarchy, different branches descend to different levels. The following organizational chart is a good example of an unbalanced hierarchy because each branch has a different depth.

![Unbalanced Hierarchy Diagram]

Many organizations have data that is organized in unbalanced hierarchies, including financial accounts, global sales territories, complex product portfolios, and organizational charts.

A robust analytical platform allows users to build reports that can elegantly display both balanced and unbalanced hierarchies. This workshop will walk you through the process of creating hierarchy reports in MicroStrategy.
GETTING STARTED

1. Open your web browser, and launch MicroStrategy Web using the URL provided to you in the Supporting Files folder
2. Once connected to MicroStrategy Web, enter the credentials provided by your instructor
3. Click on the project ‘Hierarchies Project’

CONNECT TO DATA FROM AN MDX CUBE

4. From the Web homepage, click on Create and select New Dossier

5. Click on New Data to open the Connect to Your Data interface

6. In this workshop we want to access data stored in a MSAS cube, so select the OLAP option from the available data sources
Notice that there is already an existing MDX connection labeled “MSAS”.

7. Double-click on MSAS in the MDX CONNECTIONS window and notice that AdventureWorks2014 appears in the BROWSE CATALOG section.

8. Click on AdventureWorks2014 to expand it and bring up the cubes available for analysis.
9. Drag the **Finance** cube into the drop zone on the right

![Image of dragging the Finance cube]

10. Select the checkbox next to the setting ‘**Import hierarchy as hierarchical attribute**’ on the bottom-right corner of the window

![Image of checkbox being selected]

**TIP**: A hierarchical attribute is a new object that represents an entire hierarchy and its levels. Hierarchical attributes can be placed on a grid, filtered, and sorted, much like normal attributes. By treating an entire hierarchy as a single object, MicroStrategy makes it quick and easy to build hierarchy reports.

11. Click **Finish** - note, the import process will take about 5-10 seconds. Notice that the data from the MSAS cube has now been imported as a dataset.

12. Click the **Save** button, and save the dashboard in your **My Reports** folder as **MSAS Dashboard_<your initials>** - adding your initials to the file name will help you differentiate your file from other’s later in the workshop.
13. Click OK, and then click Run newly saved dossier to return to your work.

ANALYZE YOUR DATA

Now that your dataset has been imported, you can start analyzing your data. But first, take a moment and save your dossier.

14. Expand the Account folder, and double-click on the Accounts hierarchical attribute to add it to the Rows drop zone

15. Expand the Accounts attribute to view the data by clicking on the “+” sign next to it.

16. Right-click on the Accounts attribute in the Rows drop zone and select Sort Ascending
17. Under the **Accounts** attribute in the grid click on the “+” sign associated with **Net Income, Operating Profits, and Gross Margin** – notice that all the elements are sorted in ascending order

![Diagram](image1.png)

18. Click on the “-” sign associated with **Net Income** to minimize that hierarchy

19. Click on the **Filter** tab.

![Diagram](image2.png)

20. Drag the **Accounts** hierarchy object into the **Filter panel**
21. Click on the ellipsis icon next to Accounts, and select Display Style → Check Boxes

Notice that the Accounts hierarchy object is now displayed as a filter checkbox.

22. Hover over Net Income within the Filter panel, and select it

23. Expand Net Income and uncheck Other Income and Expenses, and Taxes
24. Click Apply

![Image of Apply button](image)

Notice that after selecting **Apply**, the items for **Balance Sheet** and **Statistical Analysis** have been removed from the grid, leaving only **Net Income**.

![Image of grid with Net Income selected](image)

25. In the datasets panel, browse to **Measures → Financial Reporting**, and drag the **Amount** metric to the metrics drop zone.

Select the “+” sign next **Net Income** and then the expand **Operating Profit**, **Gross Margin**, **Net Sales**, and **Gross Sales**

![Image of expanded metrics](image)
26. Select the **Filter** Tab

27. In the Datasets panel, expand the **Date** folder

28. Drag and drop the **Date.Fiscal** hierarchy attribute to the Filter tab

29. Click on the ellipsis icon next to **Date Fiscal**, and select **Display Style → Check Boxes**
30. Expand **All Periods**, and then check only FY 2010, FY 2011, FY 2012, and FY 2013

31. Select **Apply**

**TIP:** You can fully expand the Date.Fiscal hierarchy and select different elements with which to filter the report.

32. Select the **Editor** tab, and then add **Date Fiscal** hierarchy attribute to the **Columns** drop zone of the Editor Panel above the greyed out Metric Names
Next, we will use thresholds to add color bands to the dashboard to better break out the hierarchies.

33. In the Editor, right-click on Accounts, and select Thresholds

34. Click on New Threshold

35. In the Based on drop down, select Accounts

36. Then type ‘Net Income’ in the search field

37. Select the Net Income check box and then click the blue OK button

38. Under the Format Preview, double-click on the Sample box to open your formatting options

**TIP:** Thresholds allow you to visually organize data to make a report more impactful and easier to view.
39. Choose **Dark Blue** under **Colors and Borders** and **White** for **Font**, and then click the √ button

40. Click the **New Threshold** button
41. In the Based on drop-down, select Accounts and search for “Operating Profit”

42. Select the Operating Profit check box and then click OK

43. Double-click on the Sample button for the newly created threshold

44. Choose Pale Blue under Colors and Borders and White for Font, then click the √ button
45. Click OK

You now have set the Row Header color. Next you will set the metric values to match to complete the banded layout.

46. Right-click on the Amount metric in the Metrics drop zone and select Thresholds
47. Select the Advanced Threshold Editor.

48. You will get a notification window “Save thresholds definition before proceeding to the Advanced Threshold Editor?”, click Clear to proceed.

49. Click New Threshold

50. In the Based on drop down selector select Accounts, and search for “Net Income”

51. Select the Net Income check box and click OK
52. Double-click on the **Format Preview** button

53. Select **Dark Blue** under **Colors and Borders** and **White** for **Font** and then click on the blue √ icon

54. Click **New Threshold**

55. In the **Based On** drop down selector select **Accounts**, and then search for “Operating Profit”

56. Select the **Operating Profit** check box and click OK
57. On the Accounts in List Operating Profit row, select the Format Preview button
58. Select Pale Blue under Colors and Borders and White for Font, and then click on the blue √ icon

59. Click OK

You have now set your banding across the entire grid. Your dossier should now look similar to the following image:
Navigate to the Format tab of the

Choose General Settings from the primary drop down menu and then change Columns from Fit to Contents to Fit to Container

Now would be a good time to save your work – click on the Save icon and then click OK to return to your dossier

VISUALIZE YOUR DATA

In this section, we will visualize the data imported from the MSAS cube.

Add a new visualization to your dossier by clicking the Insert Visualization button on the top toolbar
This will add a new visualization to the right of your existing grid. For our purposes, we want the grip to be at the top of the page, so let’s move the new visualization to the bottom.

64. Click on the title bar of **Visualization 2** and drag it so it sits beneath **Visualization 1**

![Visualization 1 and Visualization 2](image)

**TIP:** When you drag Visualization 2 down, you will see a solid blue line under Visualization 1. At that point let go of the mouse to release the visualization - Visualization 2 will now be below Visualization 1.

Your dossier should now look like the image below:
We're going to make **Visualization 2** a bar graph showing the percentage to total for each year.

*TIP:* Before you can create a visualization using a Hierarchy Attribute, you must have the levels of the hierarchy expanded in the visualization. Once this is done, you can then convert the grid into the desired visualization.

65. With **Visualization 2** selected (as indicated by a blue outline), go to the **Editor panel** and drag **Accounts** to the **Rows** drop zone, **Amount** to the **Metrics** drop zone, and **Date.Fiscal** to the **Columns** drop zone above the greyed-out **Metrics Names**

66. On the grid click to expand both **Net Income** and **Operating Profit**
67. Now, navigate to the **Visualization Gallery** on the far right-hand side of the interface and select the **Bar Chart** icon

This will result in a Horizontal Bar chart with four divisions. In the next section, we will change this to a percent bar graph.

![Horizontal Bar Chart Image]

68. Go to the **Editor** panel and select the **Swap** button to pivot the bar chart from Horizontal to Vertical.

![Editor Panel Image]

Now that the bar chart has been pivoted, it should look like the image below:

![Vertical Bar Chart Image]
69. Next, drag the **Date.Fiscal** attribute to the **Color By** the **Break By** drop zone.

70. In the **Break By** drop zone, below **Date.Fiscal** you’ll see three options to change the Bar Chart (**Clustered, Stacked, and Percent**) - click on **Percent**.

Your visualization is almost finished, but you notice some negative values on the y-axis. This is due to some values in the **Finance** data set being negative. We can fix that by manually setting the **Axis scale** of the graph.

71. With Visualization 2 selected, navigate to **Format** → **Data Exploration** → **Axis Scale** → **Custom** and set the min value to 0.

72. Click OK.
The axis scale will now go from 0% to 100%.

**73.** You also want to display the percent to total on the bar chart itself. With **Visualization 2** selected, navigate to **Format ➔ Shape and Data Labels** and select **Values** to enable data labels.

**74.** Set the font color to **White** and the font style to **Bold**.

You notice that the bars are displaying the actual value, not the Percent to Total. In order to display the Percent to Total value on the graph, you’ll need to create a Percent to Total metric using a MDX Level Metric calculation.

**75.** In the **Datasets** window, right-click on the **Amount** metric and select **Create Metric**.
This will bring up the **Metric Editor** window. We are now going to write a custom metric that will pass MDX SQL to the cube via an **ApplySimple** function.

76. To get started, click the **Switch to Formula Editor** button in the lower-left hand corner

![Switch to Formula Editor](image)

77. Paste the following code to perform a Percent to Total calculation via a MDX Level metric calculation. The formula is provided in the Supporting Files folder for easy copy/paste.

   ```sql
   ApplySimple("(Amount/(Amount, [Date.Fiscal].[All]))", Amount)
   ```

78. Enter **% to Total** in the **Metric Name** text box and then click **Save**
79. In the **Datasets Panel**, right-click on the **% to Total** metric, navigate to **Number Format**, and select the % icon

80. Next, select the left < sign two times to add two decimal places to the metric formatting, and select **OK**

81. With **Visualization 2** selected, drag the **% to Total** metric into the **Vertical** drop zone – directly over the **Amount** metric to replace it
82. Next drag the **Amount** metric into the **Tooltip** drop zone

Your bar graph now displays the % to Total as a data label and the actual amount values as a tooltip when a user hovers over the visualization.

83. Double-click on **Visualization 1**, and rename it to **FY Net Income**

84. Double-click on **Visualization 2**, and rename it to **FY Net Income % Totals**

85. Right-click on **Chapter 1** and rename it to **FY Income**
86. Right-click on Page 1 and rename it to FY Details

Next, we want to see how we are doing on a quarterly and year-over-year basis. To do this, we are going to use the calendar timeframe, therefore, let's create a new chapter with its own filters.

87. Select the Add a Chapter button in the upper-left corner

88. Right-click on the new Chapter 1, and rename it CY Sales

89. Right-click on Page 1, and rename it CY Sales Details

90. Expand the Date folder and drag Date.Calendar to the Rows drop zone
91. Drag the Amount metric from the Measures→Financial Reporting folder to the Metrics drop zone

92. Select the Filter tab

93. Expand the Account folder, and drag the Accounts attribute to the Filter tab

94. Click on the ellipsis, and change the display style to Check Boxes

95. Expand Net Income → Operating Profit and select Gross Margin, then click Apply

96. Next, drag Date.Calendar to the Filter tab

97. Click on the selector options, and change the display style to Check Boxes

98. Expand the Date.Calendar selector and expand All Periods → CY 2012 → H1 CY2012 and ONLY select Q1 CY 2012 and Q2 CY 2012

99. Repeat the process for the remaining quarters of 2012 and all quarters of 2013
You will now have Q1 CY 2012, Q2 CY 2012, Q3 CY 2012, Q4 CY 2012, Q1 CY 2013, Q2 CY 2013, Q3 CY 2013, and Q4 CY 2013 selected.

100. Click **Apply**

---

**TIP**: With hierarchy attributes, what you select is what you see. Since we want to display quarterly trends in a line graph, we need to unselect the yearly and half year values originally selected in the filter; otherwise they too will appear in the graph, and it will not make sense.

To view the **Amount** value for the previous year, you need to create a MDX Transformation metric.

101. Right-click on the **Amount** metric and select **Create Metric**

102. Click on the **Switch to Formula Editor** button to switch to the **Formula Editor**

103. In the **Formula Editor** screen, paste the following formula - this formula is also provided in the Supporting Files folder for easy copy/paste

```
ApplySimple("(ParallelPeriod([Date].[Calendar].[Calendar Year]), [Measures].[Amount])", Amount)
```
104. In the **Metrics Name** text box type in **Amount – LY** and click the **Save** button

105. Switch to the **Editor Tab** and drag the **Amount – LY** metric to the **Metrics** column beneath the **Amount** metric

106. Hover over the top-right corner of **Visualization 1**, select the menu icon and then choose **Duplicate** to copy the visualization
107. **Drag Visualization 1 copy below Visualization 1**

108. **Click on Visualization 1 to select it and then click on the Line Chart icon from the Visualization Gallery**

This will give you a visualization with two separate line graphs, but you want to collapse the line graphs into a single chart.
109. On the Editor tab, drag the Metric Names from the Vertical drop zone to the Break By drop zone to put both line graphs on the same axis.

Both line graphs are now on the same axis but with the same blue color.

110. To differentiate the metrics by color, take Metrics Name and drag it to the Color By drop zone.
111. Select Visualization 1 copy and open the Format tab

112. Select General Settings from the primary drop down menu, go to the Columns drop down, and select Fit to Container

113. Rename Visualization 1 to YoY Sales and rename Visualization 1 copy to YoY Details

Viewing the MDX SQL query that MicroStrategy is generating is quick and easy.

114. Select the FY Details page from the Table of Contents

115. Hover over the top-right corner of the FY Net Income visualization, click on the menu icon, and select Query Details
This will display the **Query Details** page that shows the MDX query information.

116. **Click Close** to return to your dossier.

117. **Switch to full screen by clicking on the Presentation Mode button at the top right.**

The two pages of your dossier should now look like the following:
FY Details

CY Sales Details

118. Click the save button to save your work

USING THE LIBRARY

In this section, we will move the dossier to the MicroStrategy Library.

119. Click on the Share button and select Get a link to the MicroStrategy Library - this will bring up the Share window
120. Select the **Launch** button

![Launch button](image)

121. Enter your credentials (provided in Supporting Files folder) and click **Log In** to access MicroStrategy Library

![Log In](image)

The dossier is now displayed in MicroStrategy Library, but you're not done quite yet. Let’s add the dossier to our Library.

122. In the upper-right corner of the interface, select the blue **Add to Library** button to complete the process of adding the dossier to your Library

![Add to Library](image)
123. In the upper-left corner, click the **Library** button to see the full Library of dossiers.

![Library Button](image)

You should now see the full list of dossiers available in your Library. Locate the dossier you built (remember that you saved it with your initials).

124. Click on the grey ‘i’ icon to bring up the detailed information window

![Information Window](image)

This window includes information on who created a dossier and the last time it was updated. You can also ✉️ **Export to PDF**, ✉️ **Download to MSTR File** or ✏️ **Edit**, and **Certify** a dossier from this window.

125. Click the ✏️ **Edit** button – this will reload your dossier
To certify your dossier, you have to close the dossier and certify it from the navigation window.

126. Click the “X” button in the upper-right corner to close the dossier.

127. Navigate to the My Reports folder to display your dossier.

128. Right-click on your dossier and select Properties from the available options.

129. In the Properties window that pops up, click on the Certified check box to certify your dossier.

130. Click OK.

131. Next, select the blue MicroStrategy Library button from the menu on the left-hand side of the interface.
This will bring you back to your Library. Notice that your dossier now has a gold certified ribbon on the lower-left corner of its icon – signifying that this dossier has been certified.

Congratulations! You have now completed the Ragged Hierarchies workshop.