MOBILE IDENTITY, SECURITY & COMMUNICATIONS: INTRODUCTION TO USHER TELEMETRY AND ANALYTICS
# TABLE OF CONTENTS

<table>
<thead>
<tr>
<th>Activity</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>INTRODUCTION</td>
<td>3</td>
</tr>
<tr>
<td>ACTIVITY 1: REGISTRATION</td>
<td>3</td>
</tr>
<tr>
<td>ACTIVITY 2: CREATE A NEW USHER NETWORK</td>
<td>4</td>
</tr>
<tr>
<td>ACTIVITY 3: DESIGN AND CONFIGURE BADGE</td>
<td>8</td>
</tr>
<tr>
<td>ACTIVITY 4: REGISTER BLUETOOTH BEACON</td>
<td>12</td>
</tr>
<tr>
<td>ACTIVITY 5: REGISTER PHYSICAL ACCESS SIMULATOR</td>
<td>14</td>
</tr>
<tr>
<td>ACTIVITY 6: USHER ANALYTICS</td>
<td>18</td>
</tr>
<tr>
<td>ACTIVITY 7 (OPTIONAL)</td>
<td>22</td>
</tr>
</tbody>
</table>
INTRODUCTION

You are the Operations Manager for the guest facilities and resources at your organization’s headquarters. Last year, your company made a significant investment in a visitor program. Unfortunately, you find the reporting capabilities insufficient and are actively looking for a better way to drive your bi-weekly staffing meetings with your team. You are interested in tracking facility utilization by HQ visitors, monitoring which sections of the facility are being accessed by visitors, and providing feedback to the organizations who come to visit your corporate headquarters.

Due to complexities associated with hosting an interactive workshop that incorporates physical doors, we will simulate opening doors with a web application.

ACTIVITY 1: REGISTRATION

In this activity, you will enroll in the Usher Workshop to generate an Usher badge that identifies you as a user in the Usher Workshop system.


   NOTE: Be sure to use an email address that you can access from your smartphone.
2. From your smartphone, check your email for the Usher badge invitation.

3. Open the email to retrieve your Usher badge. If you do not have the Usher application downloaded on your smartphone, select the Tap 1 option to install from the App Store (iOS) or Google Play Store (Android).

   ![Email with Usher badge invitation]

   Once the Usher application has been downloaded, return to the email and select the Tap 2 option to acquire your Usher Badge.

   ![Email with Usher badge invitation]

4. Notify the Workshop instructor when you have successfully retrieved your badge. The instructor will then assign you the role of Administrator so you will be able to create your own Usher network.

**ACTIVITY 2: CREATE A NEW USHER NETWORK**

*Prerequisite:*
Before beginning this Activity, make sure you have your purple Usher Workshop Analytics Badge and that it shows the admin label in the upper right-hand corner. If the
instructor designated you an administrator and you do not see “Admin” in the upper right-hand corner of your badge, try returning to your smartphone’s home screen and reselecting the Usher app.


6. Open the scanner in your Usher app by tapping the scanner icon, shown below on right on the iPhone and on left on Android.

7. Using your **Usher Workshop Analytics Badge**, scan the QR Code that appears on screen to log in.

*Example screen; scan the code that appears on your computer screen.*
8. In the upper-right corner, click the drop down arrow and choose **Manage Networks**.

![Image of Manage Networks dialog box]

9. Click the **Create New Network** button.

![Image of Create New Network button]

10. Complete the fields as shown and then click **Next**:  
**Badge Name:** Usher Workshop  
- **Network Name:** World - <Your Name>  
- **First Name:** <Your First Name>  
- **Last Name:** <Your Last Name>  
- **Title:** <Your Job Title>
The following screen will appear. Note that the “Go to your new network” button will remain greyed out until you obtain the new Admin badge, which will be automatically emailed to you.

11. Check your email on your smartphone for the new badge invitation. When it arrives, complete the Tap 2 step on your device to acquire your new Admin Usher Workshop badge (blue). Once your badge has appeared on your smartphone you have completed this step.
Note: This is your Admin badge. As shown in the screenshot, the upper right corner of the screen indicates “Admin”.

12. Return to your computer’s web browser and click on “Go to your new network”. As a reminder, if this button is greyed out, you have not obtained the new badge.

ACTIVITY 3: DESIGN AND CONFIGURE BADGE PROPERTIES

The Usher Badge is carried by the end-user on their smart phone. The Usher Badge can be designed using the Usher Network Manager’s WYSIWYG editor to precisely match corporate look-and-feel. Additionally, depending upon the security requirements of the Usher Network, the badge properties are highly configurable, allowing us to configure additional layers of security, such as Geo-Fencing, Time-Fencing, and requiring the use of Touch ID or PIN protection of the Usher Badge.
In this activity, we will have an opportunity to modify the design of the badge, and we will enable two settings to enhance Location Awareness.

13. First, verify that you are in the new Usher Network that you created in the prior exercise. You can verify this by looking at the name of the network displayed at the top of Usher Network Manager.

If it says anything else, you are in the wrong network. To change networks, click the down arrow by your name and select the new network that you created in the prior activity.

14. Ensure that you are on the Users and Badges tab of Usher Network Manager and look for the Badge Management section at the bottom of the page. Click on Design.
15. Experiment with the controls on this page; once you are satisfied with the look of your badge, click **Save** and your changes will render in a few seconds.

16. *Optional icon:* If you would like to create an icon for your logo and upload this, please make the image 200x200 pixels and save as a JPG or PNG file.

17. *Optional background:* If you would like to create a custom background and upload this, please make the image 640x1136 pixels and save as a JPG or PNG file.

18. Next, click on **Properties** and make the following changes to allow the Usher Network to gather a rich set of telemetry data.

19. Requirements -> Location Services: While in Use

20. Requirements -> Bluetooth: Required
21. Click **Save** and then click **X** in the upper-right corner of the panel to close the Properties dialog.

22. Check your Usher Workshop badge on your smartphone to see your new design changes. Because you have made adjustments to the Location and Bluetooth requirements for your Usher Network, you may now be prompted to accept Location Request; do so in order to complete the exercise. If Bluetooth is not turned on, you may also receive a message to enable this on your smartphone.
ACTIVITY 4: REGISTER BLUETOOTH BEACON

Bluetooth Beacons can be used with an Usher Network in a variety of ways:

23. Beacons can be placed in a facility and then used to gather precise location data on the Usher Badge holders who come within detection range.

24. When a Physical Access system is integrated with Usher (which you will do in Activity 5), beacons can be linked to specific doors or gates to make access more convenient for the Usher Badge holders.

In this example, we are interested in the use of beacons for gathering location data. The first step in deploying a beacon is to configure it, which in this activity has already been done by the Instructor. As part of this configuration step, the beacon is given a unique signature that is signified by the UUID, Major, and Minor values. Additionally, the transmission power (range) and advertising rate are set during the configuration step. Once the beacon has been configured, it can be registered with the Usher Network, which we will do now:

25. Click on the Physical Gateways tab of Usher Network Manager.
26. Click on the **beacon icon** under Beacon Configuration to manually add a beacon.

![Beacon Configuration](image)

27. Enter the following values:

- **Beacon Name**: MicroStrategy World
- **Status**: Enabled
- **UUID Identifier**: 2F234454-CF6D-4A0F-ADF2-F4911BA9FFA6
  - (note this is case sensitive)
- **Major**: 1
- **Minor**: 1
- **Message**: [Leave this blank]

28. Click the green **Add action** button and set the fields as follows:

- **Action 1**: Log user location
- **User Confirmation**: none
29. Click Add Beacon to commit the changes.

30. Click the X in the upper-right corner of the panel to close the beacon properties dialog. **NOTE:** Beacons can take up to one hour to become available to the Usher badge holders.

**ACTIVITY 5: REGISTER PHYSICAL ACCESS SIMULATOR**

Physical Access Systems ("PACS") are the systems that are deployed in buildings to control access to the doors, lifts, and gates. Usher integrates out of the box with many different types of systems, such as Lenel, Tyco, Brivo, S2, and others. It is also possible to build your own integration to systems that we don’t currently offer out-of-the-box support for. Unlike traditional PACS access, which uses a proximity card held in front of a door reader to open a door, Usher communicates with the PACS system on the back-end, where the Identity of the user and the Resource identifier are sent to the PACS through 3G/LTE or WiFi.

In this activity, we will use a simulated Physical Access System to demonstrate the use of Physical Access within your Usher Network:

31. Click on the UPACS icon under Building Access.
32. Click **Next**.

![Image](image1.png)

33. Type in the information below and click **Refresh**.

34. **Configuration Name**: Usher Workshop PACS Simulation

35. **Adapter Server URL**: [http://ec2.usherservices.com](http://ec2.usherservices.com)

36. **Adapter Service Path**: /UsherWorkshop

37. **User ID Mapping**: email

   (note: do not enter an email address; type the word “email”)

38. **SSL Bypass**: false
39. After you see **Successfully Connected**, click the **Next** button.

40. Click **Done**
41. Click the **Manage Keys Now** button.

![Manage Keys Now](image)

42. Verify that the following keys are displayed, then click the X in the upper-right corner of the panel to close the dialog.

![Manage Keys](image)

43. On your smartphone, open your **Usher Workshop Badge**.

44. Click on **Keys**, then click **All** in the upper-right hand corner, and verify that your keys are displayed as shown.

![Usher Workshop Badge](image)
Note: if you want to pin any of the keys to your Favorite Keys screen, select the heart icon next to those keys.

45. On your computer, open your web browser to http://ec2.usherservices.com/UsherWorkshop/

46. Click on the keys inside your Usher Badge to open different doors.

ACTIVITY 6: USHER ANALYTICS

Now that you have generated some telemetry data on physical access activity, it’s time to explore Usher Analytics. Using an out-of-the-box dossier, we will apply a simple filter to view the data for our Usher Network.


48. When the QR Code displays, use your new Usher Badge to scan the QR Code to log in to MicroStrategy Web.
49. If prompted on your smartphone, select **Public Network**.

![Image of Public Network selection](image)

50. After logging in, select the **Usher Analytics Self Service** folder.

![Image of Usher Analytics Self Service folder](image)

51. Select the **Shared Reports** folder.

![Image of Shared Reports selection](image)
52. Select the Dossier Reports folder.

53. Select the Usher Analytics dossier.

54. In the upper-right hand of the dashboard within the Filter Panel, click on Network to reveal a search panel.
55. Begin typing the name of your network (created in Activity 2) and select it when it appears.

56. The User Log report now reflects all user activity on the Usher Network that you had created during Activity 2.

57. Please close the dossier by choosing File > Close. When prompted, please do not save your changes.
Congratulations! You have completed today’s Usher Workshop.

ACTIVITY 7 (OPTIONAL)

The purpose of this activity is to help you to become familiar with creating your own reports and visualizations based on the Usher Analytics data.

58. In Analytics, click on Create and then choose New Report > Blank Report.

59. Under All Objects, choose Attributes.
60. Add the following attributes to the report by dragging them to the report pane.

- User
- Action Type
- Timestamp
- Latitude
- Longitude
- Network

**Hint**: click inside the search box, type the attribute name, and hit Enter to narrow the list.
61. Click the **Save** button to save your report.

62. Save the report to "**My Reports**", and name your report **LASTNAME_FIRSTNAME**.

63. After saving, click Run newly saved report.
64. Choose the **Tools** menu and then select **Create Dossier**. This will bring you to the Dossier Editor.

65. Place your cursor on the Visualization 1 title bar and click on the three dots that appear on the right.
66. A cascading menu will appear. Choose **Change Visualization > Map**.

![Change Visualization Menu]

67. Click on the **Filter** panel and then drag Network from the Datasets panel to the Filter panel.

![Filter Panel with Network Dragged]

68. Select the three dots next to the new filter you placed in the Filter panel to expand the cascading menu, and choose **Display Style > Search Box**.

![Display Style Menu]
69. Click on the **Format** tab, and change **Zoom Behavior** to **Dynamic**.

70. Click on the **Filter** tab again, and click in the Search Network box to search for your own network (created in Activity 2).

71. Now, by manipulating the filter criteria, you can see either your own network or all networks that have been created by others during this Usher Workshop.
72. Please close the dossier by choosing **File > Close**. When prompted, please do not save your changes.

73. Log out by clicking the User button in the upper-right and choosing **Logout**.

Congratulations! You have completed the Usher Workshop.